エラー
Error: (ServiceUnavailable) Embulk::Input::TwitterAdsAnalytics::ServiceUnavailable
{"errors":[{"code":"SERVICE_UNAVAILABLE","message":"Service unavailable due to request timeout; please try the request again later"}],"request":{"params":{}}}
原因
X Ads APIへのリクエストがタイムアウトしたことが原因です。
対処法
X adsAPIの障害などによりSERVICE_UNAVAILABLE エラーが一時的に発生するケースがあります。
一定時間後に再実行いただくことで、ジョブが正常に完了することが多いです。
TROCCOでは以下の対応策をご用意しております。
■ ワークフローのリトライ設定を活用する
ワークフロー定義にて「リトライ回数」を設定いただくことで、一定時間後に再度ジョブを自動実行させることが可能です。
(参考)リトライ回数 - ワークフロー定義について
(補足)
SERVICE_UNAVAILABLE エラーが発生したことで、ジョブは成功したが、処理時間が長くなったという事象があります。その原因は以下になります。
■ ジョブ実行時の内部リトライ仕様について
SERVICE_UNAVAILABLE エラーが発生した場合、TROCCOでは最大5回まで自動でリトライ処理を行います。
このリトライには一定の待機時間が挟まれるため、リクエストが最終的に成功した場合、通常よりジョブの実行時間が長くなることがあります。
■ タイムアウト設定のご活用
SERVICE_UNAVAILABLE のような一時的なエラーに対して、ジョブ全体の処理時間を制御することも可能です。
TROCCOでは、下記2種類のタイムアウト設定をご用意しております。
- すべてのジョブに対してタイムアウトを設定する
(参考)タイムアウト設定 - ワークフロー内でタイムアウトを設定する
(参考)タイムアウト設定 - ワークフロー定義について
それぞれ運用に合った設定をお試しいただき、ジョブの安定稼働にお役立てください。
コメント
0件のコメント
記事コメントは受け付けていません。